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1 Cardiac Signals 

1.1 Aim of Experiment 

 

The MEA-System can be used for in vitro studies of the electrical properties of cardiac myocytes 
and, for example, effects of drug candidates on field potential waveforms and kinetics. 
Primary cardiac myocytes can be easily harvested from fertilized chicken eggs, or from neonatal 
rat or mouse. It is also possible to obtain murine and human embryonic stem cells derived 
from embryoid bodies. There is also one cardiomyocyte cell line from mouse that retains  
a differentiated cardiac myocyte phenotype: HL-1 from Dr. W. Claycomb. 

Plated cells form a syncytium and start beating spontaneously after a couple of days,  
or contract after electrical stimulation (pacing). The two-dimensional MEA layout is ideally 
suited for showing the waveform propagation and measuring the conduction velocity  
in a cardiomyocyte culture. 

Simultaneous recordings of action potentials (with intracellular electrodes) and field potentials 
(with extracellular electrodes) have shown that there is a correlation between the rise time  
of the cardiac action potential (AP) and field potential (FP) as well as between AP and FP 
duration. A correlation between the waveform components and the ion channel activities 
was shown by using ion channel blockers or by depleting the medium of the respective ions 
(Reference: "Determination of Electrical Properties of ES Cell-derived Cardiomyocytes. Using 
MEAs”, Jürgen Hescheler et al., Journal of Electrocardiology, Vol. 37 Supplement 2004; 
"Estimation of Action Potential Changes from Field Potential Recordings in Multicellular Mouse 
Cardiac Myocyte Cultures", Marcel D. Halbach et al., Cell Physiol Biochem 2003;13:271 to 284). 

The high and short peak of the extracellular field potential can be correlated to the rapid 
component of the depolarizing sodium current. The following plateau follows the time course  
of the slow calcium current; and the following positive or negative peak correlates to the slow 
rectifying K+ current (IKr). The polarity of this peak depends on several parameters, for example, 
the proximity of the cell layer to the measuring electrode, and cannot be predicted, but this fact 
does generally not matter for this assay. 
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The field potential duration corresponds to the action potential duration, which can be correlated 
to a QT interval in an electrocardiogram. It is measured from minimum of the Na+ peak to the 
maximum / minimum of the IKr current peak. 

The effects of tested drugs on QRS duration and amplitude, local activation time, T wave 
amplitude, time of maximal slope of T wave, QT interval duration, and ARI (activation 
refractory interval) can be analyzed with the MEA-System. 

Typical applications are: 

 Drug testing for effects on cardiac signal waveforms, for example QT prolongation. 

 Analysis of changes in the signal propagation kinetics. 

 Cocultures of stem cells and primary cells for basic research and for gaining insights into 
transplantation options and techniques. 

 Characterizations of cells for cardiac properties, for example, of cardiomyocytes derived  
from stem cells. 

You will see in this tutorial how a virtual rack is set up for those purposes, and how typical  
signal waveforms look like. Please note that the amplifier filter settings affect the waveforms  
of recorded signals. Please see additional documentation, for example, the MEA1060 Manual  
or MEA Application Notes for more information on this matter. 

The demo data shown here was recorded from chicken embryonic cardiomyocytes at a sampling 
rate of 10 kHz with a gain of 1200, and a bandwidth of 1 Hz to 3 kHz. The demo data 
Cardiomyocytes_QT.mcd was filtered with a digital 2 Hz high pass filter in MC_Rack. 

You will learn in this chapter ... 

 How to define basic functions in your rack configuration: 

 Monitoring cardiac activity (Trigger Detector, Data Display). 

 Generate an excitation map (Analyzer, Parameter Display, False Color plot). 

 Averaging data for increasing the signal to noise ratio (Averager). 

 Automatically extract the QT interval (Analyzer). 

 Monitor the QT interval (Parameter Display). 

 How to customize the rack: 

 Modify the display layout (all display types). 

 More details: 

 Manually measure the QT interval, for example, from averaged data  
(Crosshair feature  of the Data Display). 



MC_Rack Tutorial: MEA Application Examples 

8 

Excitation map 

The following rack and data file demonstrate the two-dimensional signal propagation. 

 Rack file: Cardiomyocytes_ExcitationMap_Demo.rck  

 Data file: Cardiomyocytes_60Ch.mcd 

QT Prolongation 

This rack and data file shows very prominent IKr peaks, and is therefore well suited  
for showing how to extract the QT interval from cardiac field potentials. 

 Rack file: Cardiomyocytes_QT-Analysis_Demo.rck  

 Data file: Cardiomyocytes_QT.mcd 

Please see also the MEA Application Notes for more information on the preparation  
techniques and experiments. 

1.2 Preparations 

We recommend that you take some time for rebuilding the virtual rack for this application step  
by step in this tutorial, but if you prefer having a look at the completed rack or if you get stuck 
during the tutorial, you can also open the rack file "Cardiomyocytes_ExcitationMap_Demo.rck". 
Click Open on the File menu to open the rack file. 

1. Copy the complete MC_Rack Tutorial folder from the installation volume into the MC_Rack 
program directory with the following path "c:\Program Files\Multi Channel Systems\MC_Rack\" 

2.  Start MC_Rack or click New on the File menu to generate a new virtual rack file configuration. 

3. Click  on the toolbar to add a Replayer to your virtual rack. 

4. In the tree view pane of the virtual rack, select the Replayer and click the Replay File tab.  
Click the Browse button and browse to the Offline subfolder of the Tutorial folder,  
and load the data file Cardiomyocytes_60Ch.mcd into the Replayer. 
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1.3 Monitoring Cardiac Activity 

1. On the Edit menu, click Add Trigger to add a Trigger Detector to your virtual rack. 

2. In the tree view pane of the virtual rack, select the Trigger Detector, and click the Trigger  
tab and select the channel that you want to use as a trigger, for example, channel 51.  
You can change the detection threshold level and the dead time on this page, but this  
is not necessary in the moment. 
 

 
  

3. In the tree view pane of the virtual rack, select the Trigger Detector and click  on the  
toolbar to add an oscilloscope-like Data Display in series with the Trigger Detector to the 
virtual rack. (If you would put both instruments in parallel, you would not be able to use the 
trigger stream generated by the Trigger Detector for triggering the display, because virtual 
instruments can only use the output streams of other virtual instruments that are upstream in  
the virtual rack tree.) Have a look at the display settings (Layout tabbed page) and make sure  
an 8x8 MEA Channel Map is loaded as the Channel Map, and Electrode Raw Data as the  
data input stream (see Data tabbed page). 

4. In the tree view pane of the virtual rack, select the Display 1, click the Window tab,  
and click Start on Trigger. Trigger 1 is preselected, as it is the only available trigger  
stream in the rack. 
 

 
  

5. In the Data Display, select the option Peak Detection. 

6. Click Start  (either on the Measurement menu, the toolbar, or the Rack tabbed page)  
to start the replaying of the data. 
 
Each virtual instrument in the rack configuration starts to process the channels and data  
streams that were assigned to it. For example, data is graphed in the displays, and so on.  
You can adjust the replaying speed on the Replayer tabbed page of the Replayer. 
 
Sweeps triggered on the activity of channel 51 are plotted in the Data Display. You see cardiac 
activity on all channels.  
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7. Zoom in the x-axis to see the different kinetics on different channels. 
 

 
 
You can see that the signal originates from the bottom right corner of the MEA and  
propagates to the upper left. Relatively to the trigger event (on channel 51), the signal  
appears at time = 30 ms at, for example, electrode 77, and it takes about 40 ms until  
it appears at time = 10 ms at electrode 12. 
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1.4 Signal Propagation 

For measuring the signal propagation, you will extract the time point of the minimum (t-Min)  
or maximum (t-Max) of the fast sodium peak. 

1. Remove the Display 1 from the rack by clicking on the Display 1 in the tree view of the virtual 
rack and pressing the DEL key or by clicking Delete Instrument on the Edit menu. 

2. On the Edit menu, click Add Analyzer to add an Analyzer to your rack, again, in series with  
the Trigger Detector. 

3. In the tree view pane of the virtual rack, select the Analyzer, and click the Channels tab.  
Select all Electrode Raw Data channels. 
 

 

4. Click the Analyzer tab and select the parameter t-Max (or t-Min). 
 

 

5. Click the ROI tab and select the option Start On Trigger 1. The Analyzer display opens.  
You can now define the region of interest (ROI) directly in the display or on the ROI page. 
 

 

6. Click the start button and zoom in the display so that you can see the waveforms clearly  
on all channels. 
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7. Drag the ROI sliders such as that all signals from all electrodes are inside the ROI, or enter 
appropriate values into the T1 and T2 text boxes on the ROI page, for example T1 = 30 ms  
and T2 = 15 ms. T1 defines the left border, and T2 defines the right border of the ROI frame. 
 

 
 
On the Edit menu, click Add Parameter Display. The Parameter Display can be configured  
as an excitation map. 

8. In the tree view pane of the virtual rack, select the Parameter Display and click the Data tab. 

9. Select the parameter t-Max. As plot type, select the False Color plot. 
 

 

10. Click the Color tab. Select any color map, for example, the Hot color map. The y-value ranges  
of the plot are now assigned to the colors of the false color map. You have to select a proper 
range so that the color assignment makes sense, that is, if the range is too wide, you will not  
see any differences in the color; if the range is too narrow, the colors will get into saturation,  
that is, black. 
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11. Click the Ranges tab. Enter an appropriate range that starts with the lowest value for  
the parameter of choice t-Max and that stops with the highest t-Max value on the MEA.  
As you see an excitation at about 30 to 10 ms (in relation to the trigger event) on different 
channels, a range from 30 to 10 ms is appropriate. 
 

 

12. On the Measurement menu, click Start to start the replaying of the data file. 

 

You can see the excitation spreading nicely from the lower right corner to the upper  
left corner. Low time values (= early signals) appear dark, the later a signal arrives  
at the electrode, the lighter gets the color, up to light yellow. 
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1.5 Averaging Cardiac Signals 

1. On the Edit menu, click Add Averager to add an Averager to the virtual rack (in series to the 
Trigger Detector). 

2. In the tree view pane of the virtual rack, select the Averager and click the Settings tab. 
In this page, a trigger is defined for the Averager, and the window extent of the cutout relative 
to the trigger event. 

3. Select the Trigger 1 that is generated by the Trigger Detector. (It is also possible to set up  
a new trigger for the Averager on the Trigger tabbed page.) Select the number of windows that 
should be summed up, in the range of 30. Select an appropriate Start Time and Window Extent 
(relative to the trigger event) for the about 200 ms long signals, for example 50 ms and 400 ms. 
 

 

4. On the Measurement menu, click Start to start the Replayer. Select Peak Detection  
in the Averager window and zoom in the axes. 
 
The data traces in each window are summed up until the target number of windows is reached. 
The summed up signal generates the data stream Averager 1, which can be saved with the 
Recorder. 

You can see that the signal-to-noise ratio and signal quality improves significantly with each 
window that is summed up. 
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1.6 Automatic Extraction of the QT Interval 

You can use the Analyzer to automatically extract the QT interval, measured from the fast 
sodium peak to the maximum (or minimum, depending on the polarity of the signals) of the  
IKr current peak. Select channels of interest that show a very clear repolarization waveform. 

In triggered mode, the Analyzer extracts the parameters of interest from a distinct time 
window relative to the trigger event, the region of interest (ROI). As you need a different 
region of interest for extracting the time point of the IKr current peak than for the time point  
of the fast sodium peak, you need to set up a second Analyzer, based on the raw data stream. 
(You cannot use averaged data for an automated analysis in the current version of MC_Rack.) 

As the cardiomyocytes are electrically coupled to each other, it does generally not make much 
sense to analyze the QT interval on more than one electrode. As the parameters of interest  
are extracted from the region of interest relative to the trigger event, it is ideal to extract  
the QT interval from the channel that triggers the Analyzer (channel 51 in this example).  
(If you want to extract the interval from multiple channels, there will be different time shifts  
on the other channels, as the signal arrives at different time points at different electrodes.  
You can of course also define multiple triggers on different channels and set up an individual 
Analyzer for each electrode, but this will be on the cost of computer performance.) 

1. On the Edit menu, click Add Analyzer to add an Analyzer to your rack (in series with  
the Trigger Detector). You can rename the Analyzer to distinguish it from the other. 

2. In the tree view pane of the virtual rack, select the Analyzer, and click the ROI tab.  
Select Start on Trigger 1, and enter values for T1 and T2 so that the ROI will approximately 
include the complete waveform, for example 0 and 200 ms. 
 

 

3. Click the Analyzer tab, and select the t-Max parameter for extracting the time point  
of the maximum inside the ROI. 
 

 
  



MC_Rack Tutorial: MEA Application Examples 

16 

4. Click the Channels tab. Deselect all electrodes by clearing the check box, and select  
the electrodes of interest, for example, electrode 51. Only the selected channel will appear  
in the Analyzer window. All other window slots appear empty. You may want to customize  
the display layout at this point. 
 

 
  

5. Start the Replayer to view the traces, and zoom in the axes so that you can clearly see  
the waveform. Adjust the region of interest by dragging the T1 and T2 cursors, if necessary,  
so that the IKr peak is safely inside the ROI. 
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1.7 Customizing Displays 

As it may not be useful to extract parameters like the QT interval from all channels, you can set up 
your custom layout for the Analyzer and Parameter Display (this is true for all displays), to save 
space on the screen. You may be interested only in one or two channels. (Remember: You can save 
the raw data or extracted parameters of all channels in the Recorder.) 

1. In the tree view pane of the virtual rack, select the Analyzer or the display that you want to 
customize and click the Layout tab. The default layout is loaded. In the Rows and Columns 
boxes, you can now modify the layout. 

2. Type or select the number of Rows, for example 1, and the number of Columns, for example 1. 
On the right, a linear layout with two channels appears. 

Assign the channel numbers to the empty slots, for example channel 51: Click to select the empty 
slot in the white layout pane, then pick 51 from the Channel list. The active slot is highlighted by 
a dotted line. The Analyzer Display is updated accordingly. 
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1.8 Monitoring the QT Interval 

You can plot the extracted time point relative to T1 of  the ROI. For plotting extracted 
parameters, we will need a Parameter Display, which features are optimized for  
Parameter streams. 

 On the toolbar, click  to add a Parameter Display to your rack. You can rename it so that  
you will recognize it later. 

Setting the window extent 

As this demo data file has about 30 s total recording time, 30 s will be fine for the x-axis range.  
As the duration cannot be longer than the ROI, that is, 200 ms, you can enter 200 ms for the  
y-axis. 

1. In the tree view pane of the virtual rack, select the Parameter Display, and click the Ranges tab. 

2. Enter 30 s for the x-axis range, and adjust the y-axis to 200 ms. 
 

 

1. Click Start to generate the plots. 

The QT interval is stable (in the range of 170180 ms) in this control experiment  
with no drug application. 
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1.9 Manual Measurement of the QT Interval 

If you need the averaged data as the basis for the analysis, you can measure the parameter  
with the crosshair tool. As the Na+ peak corresponds to the trigger event, the time point of  
the T wave is the relevant parameter. 

1. Right-click on the display and select the option Display Crosshair. 
A fine dotted line at the position of the mouse pointer. 

2. Move the mouse pointer on the T wave peak. You can now read the time point and amplitude  
of the peak on the scale. In this example, the QT interval is about 180 ms long. 
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2 Event-Based Analysis of Cardiac Activity 

2.1 Aim of Experiment 

 

This chapter describes how cardiac signals can be automatically detected with the Spike Sorter. 
The signal rate and the interspike interval (ISI) as parameters that characterize the beating 
rhythm can be monitored online during the experiment, and can be saved together with the  
raw data. The export features of the event-based parameter displays allow a direct export of  
the extracted parameters in universal ASCII format, or as a graphics file. 

The demo data used in this part of the tutorial was recorded from a cardiomyocyte cell line  
from mouse that retains a differentiated cardiac myocyte phenotype: HL-1 from Dr. W. Claycomb. 

You will see in this part of the tutorial how a virtual rack is set up for those purposes,  
and how typical signal waveforms look like. Please note that the amplifier filter settings  
affect the waveforms of recorded signals. Please see additional documentation, for example, 
the MEA1060 Manual or MEA Application Notes for more information on this matter. 

The demo data file Cardiomyocytes_HL1.mcd shown here was recorded from HL-1 cells  
at a sampling rate of 10 kHz with a gain of 1000, and a bandwidth of 1 Hz to 3 kHz. 

 Rack file: Cardiomyocytes_HL1_Demo.rck 

 Data file: Cardiomyocytes_HL1.mcd 
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You will learn in this chapter ... 

 

 How to define basic functions in your rack configuration: 

 Monitor cardiac activity (Trigger Detector, Data Display). 

 Signal detection (Spike Sorter). 

 Analyzing the signal rate and interspike interval (Spike Analyzer). 

 Monitoring the signal rate and interspike interval (Spike Analyzer Display). 

Please see also the MEA Application Note "HL-1 Cardiac Cell Line by Dr. W. Claycomb" for more 
information on the preparation techniques and experiments available for download on the web 
site of Multi Channel Systems MCS GmbH. 

2.2 Preparations 

We recommend that you take some time for rebuilding the virtual rack for this application step  
by step in this tutorial, but if you prefer having a look at the completed rack or if you get stuck 
during the tutorial, you can also open the rack file "Cardiomyocytes_HL1_Demo.rck".  
Click Open on the File menu to open the rack file. 

1. Copy the complete MC_Rack Tutorial folder from the installation volume into the MC_Rack 
program directory with the following path "c:\Program Files\Multi Channel Systems\MC_Rack\" 

2.  Start MC_Rack or click New on the File menu to generate a new virtual rack file configuration. 

3. Click  on the toolbar to add a Replayer to your virtual rack. 

4. In the tree view pane of the virtual rack, select the Replayer and click the Replay File tab.  
Click the Browse button and browse to the Offline subfolder of the Tutorial folder,  
and load the data file Cardiomyocytes_HL1.mcd into the Replayer. 
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2.3 Monitoring Cardiac Activity (HL1) 

1. On the Edit menu, click Add Trigger to add a Trigger Detector to your virtual rack. 

2. In the tree view pane of the virtual rack, select the Trigger Detector, and click the Trigger  
tab and select the channel that you want to use as a trigger, for example, channel 66. You can 
change the detection threshold level as well on this page (if the signal size is smaller or the noise 
level higher), but this is not necessary in the moment. Increase the dead time to the expected 
waveform length (here about 100 ms), to make sure that one signal is detected only once,  
as a single event. 
 

 
  

3. In the tree view pane of the virtual rack, select the Trigger Detector and click  on the toolbar 
to add an oscilloscope-like Data Display in series with the Trigger Detector to the virtual rack. 
(If you would put both instruments in parallel, you would not be able to use the trigger stream 
generated by the Trigger Detector for triggering the display, because virtual instruments can 
only use the output streams of other virtual instruments that are upstream in the virtual rack 
tree.) Have a look at the display settings (Layout tabbed page) and make sure an 8x8 MEA 
Channel Map is loaded as the Channel Map, and Electrode Raw Data as the data input  
stream (see Data tabbed page). 

4. In the tree view pane of the virtual rack, select the Display 1, click the Window tab, and click 
Start on Trigger. Trigger 1 is preselected, as it is the only available trigger stream in the rack. 
 

 
  

5. In the Data Display, select the option Peak Detection. 



Cardiac Signals 

23 

6. Click Start  either on the Measurement menu, the toolbar, or the Rack tabbed page,  
to start the replaying of the data. 
 
Each virtual instrument in the rack configuration starts to process the channels and data streams 
that were assigned to it. For example, data is graphed in the displays, and so on. You can adjust 
the replaying speed on the Replayer tabbed page of the Replayer. 
 
Sweeps triggered on the activity of channel 66 are plotted in the Data Display. You see signals 
only on a few channels, because the conduction velocity of this cell type is very slow, and 
therefore, the time lag between the area, where the excitation starts to spread and other areas 
on the MEA is quite high. Therefore, you should increase the x-axis range to see the overall 
activity. 

Zoom in the x-axis to see the different kinetics on different channels. 
You now see there is cardiac activity on a majority of channels.  
 

 
 
The excitation starts at electrode 66 (which also triggers the display). Relatively to the trigger 
event (on channel 66), the signal appears at time = 50 ms at one of the neighboring electrodes  
# 55, and it takes about 460 ms until it appears at electrode 51. This documents a very different 
kinetic behavior as, for example, the chicken embryonic cardiomyocyte culture shown in chapter 
"Cardiac Signals", where the signal spread over the complete MEA in only 40 ms. 

A false-color excitation map as shown in the demo rack 
Cardiomyocytes_ExcitationMap_HL1.rck illustrates the signal spreading very well. A detailed 
explanation how to set up an excitation map is given under "Signal Propagation" in chapter 
"Cardiac Signals". You should use channel 66 for triggering, as the signal starts to spread from 
here, and because the signal quality is very good on this channel. 
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2.4 Signal Detection (HL1) 

The Spike Sorter is a general event detector for neuronal or cardiac applications that can either 
operate in two modes: One method uses a threshold, the other recognizes the amplitude and 
slope of a waveform. Both methods regard either the rise or the fall of a signal, depending on 
the settings. The Spike Sorter has a special display where you can adjust the spike detection level 
for each channel separately with the mouse. The Spike Sorter is called Spike Sorter because  
it also has a sorting functionality, which is used for spike analysis, but does not make much sense 
for cardiac applications. Therefore, it is not explained in this chapter. 

There are two modes for detecting spikes with MC_Rack. The Threshold method is especially 
useful if the overall baseline is stable, and signals appear approximately on the same height.  
You can set the detection level for each channel separately (manually or automatically), or you 
can choose the same level for all channels. If you have an unstable baseline, signals will be missed, 
or noise signals may be detected as signals with the threshold method. In this case, the Slope 
method is more appropriate. As the baseline is very stable in this experiment, we will use the 
(easier) Threshold mode. 

1. On the toolbar, click  to add a Spike Sorter to the virtual rack. 
The Spike Sorter display appears. 

2. Select the option Peak Detection in the Spike Sorter display. 

3. Click the Channels tab and assign the Electrode Raw Data stream to the Spike Sorter. 

4. Click the Start button and zoom the display until you can see the signals clearly. You see that  
the baseline is on a similar level for all channels and that the spikes are quite small (approximately 
10 to 20 μV). 
 
In contrast to the triggered display we used before, this display operates in a continuous 
(oscilloscope-like) mode: The displayed data is not synchronized to a trigger event. The refresh 
rate of the display is defined by the x-axis range selected from the drop-down list in the display 
header. For the slow signal rate of cardiac signals, a refresh rate of 1 or 2 s is fine. 

5. In the tree view pane of the virtual rack, select the Spike Sorter. Click the Detection tab.  
Make sure the Threshold method is selected. You can now set the detection threshold.  
Start with a value of 100 μV, for example. 

6. Type in 100 in the text box. This value does apply now to the selected channel.  
Under Apply to All, click Level to apply this detection level to all channels. 
You see that this level is fine for most, but not for all channels, as the signal amplitude differs. 

7. You could now adjust the threshold level for each channel separately. A more convenient 
alternative is to use the Automatic feature to automatically assign an individual detection level 
to each channel. The standard deviation of each data trace is used to estimate its signal threshold. 
A time interval of 500 ms is used to calculate the standard deviation. You set the factor, by which 
the standard deviation is multiplied. The sign of the factor determines whether the spike 
detection level is positive or negative. You generally will use a negative factor. A value between  
-10 and -20 is generally appropriate for larger cardiac signals. The smaller the signals, the lower 
you need to set the StdDev parameter. The higher you set the parameter, the more strict will be 
the signal detection. As there are also smaller signals here, you should start with a lower value. 
For example, enter a standard deviation of 10, and click Refresh to calculate the standard 
deviation and apply the result. 
 
The detected waveform appears in a different color on the display. The detection level 
determined for a particular channel by the Automatic feature is visible as a horizontal straight 
line. For example, the threshold was set to 50 on channel 34, and to 95 on channel 44 (with a 
higher noise level). 
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8. You can then fine tune the detection level by dragging the horizontal line of each channel in  
the Spike Sorter display with your mouse. This might be necessary, for example, on channel 43, 
where the signal to noise ratio is not so good. 
 
As a single signal crosses the threshold several times, it is necessary to increase the dead time,  
that is, the time following a detection event during which the Spike Sorter will not accept  
a new signal. 
 

 

9. In the tree view pane of the virtual rack, select the Spike Sorter and click the Settings tab. Enter  
an appropriate dead time, so that a single signal is not detected multiple times. As the waveform 
is about 100 ms long, 100 ms is an appropriate dead time. The Pre- and Post-Trigger times define 
the cutout length. As we are not interested in the cutouts, but only in the detection events, we 
can set the cutout times to zero. The generated Spike data stream will then contain only the time 
points of the detection events. (This is not important for monitoring, but only for recording to  
a data file.) 
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2.5 Analyzing the Signal Rate 

1. On the toolbar, click  to add a Spike Analyzer in series with the Spike Sorter to the  
virtual rack. (You cannot put the Spike Analyzer in parallel to the Spike Sorter, because  
virtual instruments can only use the output streams of other virtual instruments that are  
upstream in the tree view as input streams.) 

2. In the tree view pane of the virtual rack, select the Spike Analyzer. Click the Channels tab. 

3. Select all channels of the Spikes data stream. (You could deselect channels for saving computer 
performance or hard disk space in a real experiment situation.) 

4. Click the Analyzer tab. 

5. Select the parameter of interest, or both the Interspike Interval and the Rate. 
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2.6 Monitoring the Signal Rate 

For plotting parameters that were extracted by the Spike Analyzer, we will need a Spike 
Analyzer Display, which features are optimized for graphing Parameter streams. The Spike 
Analyzer Display can plot the Interspike Interval and the Rate. If you want to monitor both 
parameters in parallel, simply set up two Spike Analyzer Displays in your virtual rack. 

1. In the tree view pane of the virtual rack, select the Spike Analyzer and click  on the  
toolbar to add a Spike Analyzer Display in series with the Spike Analyzer to the virtual rack. 
(It would not be possible to add the Spike Analyzer Display in parallel to the Spike Analyzer, 
as the replayed data file does not contain any parameter streams as input streams for the display, 
and virtual instruments can only use the output streams of other virtual instruments that are 
upstream in the virtual rack tree.) 

2. In the tree view pane of the virtual rack, select the Spike Analyzer Display. Click the Layout tab 
to load the MEA Channel Map. 

3. Click the Data tab and select the Spike Parameter 1 stream. Select the parameter of interest, 
that is, either the Interspike Interval or the Rate. 
 

 

4. Start the Replayer. The signal rate is plotted over time. You need to adjust the axes to see  
the data points. 

5. Click the Ranges tab and adjust the ranges. For example, set the x-axis range to 25 s,  
and the y-axis range from 0 to 5 Hz. (You can see by subtracting the Start and Stop times  
on the File Info page of the Replayer that the total file length is 26 s.) 

 

The signal rate is very stable on most channels at about 0.5 Hz. You easily detect a short 
arrhythmia on some electrodes, for example, # 45. 
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3 Saving the Rack and Saving Data 

3.1 Saving a Rack 

Save the virtual rack configuration if you like to keep it for future use, for example  
for an offline analysis of identical data recorded in another experiment. 

1. On the File menu, click Save As. 

2. The Save As dialog box opens. 

3. Browse your folders and select a path. 

4. Enter a file name and confirm by clicking Save. 

The file extension for the rack files is .rck. 

3.2 Selecting Data Streams for Recording 

MC_Rack's philosophy is to strictly separate the actions of all virtual instruments in a rack.  
That means, that you could record to hard disk completely different data streams and channels 
than you monitor on the screen. This has the advantage that you can store exactly the channels 
you are interested in, but it also has the slight disadvantage that all virtual instruments have to be 
set up separately. Please be especially careful when configuring the Recorder, to avoid data loss. 

When you have finished setting up the rack, you can select the data streams and channels that 
you want to save to the data file specified in the Recorder. 

Selecting data streams and channels for recording 

The fate of each single channel is independent from other channels. You can pick exactly the 
channels you like to save from all generated data streams. For example, you can decide to save 
only one channel of raw data, but the peak-to-peak amplitude results of all, or of a specific 
selection of channels. 

1. Select the Recorder in the virtual rack tree view pane and then click the Channels tabbed page. 
On the white pane on the left of the Channels page, you see the data streams that are available 
with your rack configuration. When replaying data, you are generally more interested in the 
parameter data streams, but you can rerecord the raw data as well, in case that you want to save 
the raw data and the extracted parameters to the same data file. 
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2. Click the data stream that you are interested in, generally the parameter streams. 
The available electrode channels appear in a button array on the right side. Parameter stream 1  
is generated by the first analyzer in the rack (here: for extracting the peak-peak amplitude), 
parameter 2 is generated by the second analyzer (here: for extracting the slope). 
 

 

3. You can now either select all channels by clicking the check box next to the data stream name,  
or you can pick single channels by clicking the corresponding buttons. For more information, 
please see "Channel Selection" in the MC_Rack Features section. Only data from the selected 
channels will be saved to the hard disk. 

3.3 Creating a Data File 

If you want to write the parameters that you will extract in an offline analysis to the hard disk, 
you have to specify the file name and path in the Recorder. (It is not possible to change or 
overwrite existing data files in MC_Rack, for example, adding the spike rate to an existing data 
file, but you can record the raw data together with the spike rate stream to the same file.) 

Choosing the file name and path 

1. Click the Recorder tab. 

2. Browse your folders and select a path. 

3. Type a file name into the text box. 

4. Confirm by clicking Save. 

The data file is then generated automatically when you start MC_Rack in recording mode.  
The file extension for the data files is *.mcd. 
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File size limit 

When the maximum file size specified by the user has been reached, a new file is generated 
automatically. The file name is extended by four digits, counting up, for example  
LTP-Parameters0001.mcd, LTP-Parameters0002.mcd, and so on. 

If you rather prefer that the recording is completely stopped when a file has reached the 
maximum size, please select the option Auto Stop. 

For information on more options, please see "Generating Data Files" in the MC_Rack Features 
section. 

Selecting data streams and channels 

As has been said before, the fate of each single channel is independent from other channels. 
You can pick exactly the channels you like to save from all generated data streams. For example, 
you can decide to save only one channel of raw data, but the peak-to-peak amplitude results 
of all, or of a specific selection of channels. 

 Click the Channels tab. 

As long as the rack is still empty, you see an empty box. There are no channels available at this 
point, because you have not chosen a data source yet (MC_Card for online data acquisition or 
Replayer for replaying data files). Without a data source, there are no data streams available  
for recording. Remember later, when you have completed the rack, to assign the channels that 
you like to save to the data file to the Recorder. 

After you added a data source, you will see the electrode raw data streams provided by the data 
source (for example, electrode raw data, analog data, and digital data from the MC_Card, or the 
data streams included in the data file loaded into the Replayer). If the rack file contains virtual 
instruments that generate data streams such as Spikes from a Spike Sorter or Parameter streams 
from an Analyzer, these data streams will be available for recording as well. 

3.4 Starting Data Acquisition and Recording 

Now that you have completed the virtual rack, you are ready to start the rack. 

 Click Start  (either on the Measurement menu, the toolbar, or the Rack tabbed page)  
to start the data acquisition. Each virtual instrument in your rack starts to process the channels 
and data streams that were assigned to it. 

 Click first Record  and then Start  to write data to the hard disk. The data from the 
electrodes selected in the Recorder is saved to the file and location specified in the Recorder. 

 

 Click Stop  to stop the data acquisition. 

 

Warning: Only data of the channels and data streams that were selected in the Recorder are 
saved in your data file when you start a recording. Data is only saved to the hard disk when the 
red Record button is pressed in. Make always sure that you have selected all channels of interest, 
and that the Record button is active before starting an experiment to avoid data loss. 

 


