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1 Spike Activity (Organotypic culture) 

1.1 Aim of Experiment 

 

Organotypic slices of the dendate gyrus (DG) and the entorhinal cortex (EC) taken from  
a PND 6 rat were co-cultured on MEAs for seven days. Both subregions showed an independent 
spontaneous spike activity. 

In an acute experiment, the slice (generally from adult animals) is used directly after preparation 
and discarded after the experiment. Slices from neonatal animals can also be kept in prolonged 
culture, over several weeks or even months, as so called organotypic cultures (OTC).  
Even though the synaptic organization is not exactly the same as in native tissue, the main 
characteristics and functions are preserved. OTCs have the advantage that they allow to observe 
the electrophysiological activity over a longer period of time on the same slice. Also, organotypic 
slices tend to thin out on the MEA, which is advantageous for optical imaging. OTC experiments 
are especially useful for longterm experiments, for example, for monitoring the development 
of the neuronal networks and its electrophysiological activity, the behavior of co-cultured slices 
from different regions and the regeneration of tissue (like in this experiment), or longterm  
drug effects. 

The demo data used in this part of the tutorial was kindly provided by Dr. Frank Hofmann, 
University of Heidelberg, Germany. 

Task 

Extract spikes and visualize the two-dimensional distribution of activity by an offline analysis; 
graph, print and save the results. 
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Note: In this chapter, you will set up an offline analysis rack (for the demo data file) step by step. 
You can set up a virtual rack for online recordings and analysis likewise, simply add the MC_Card 
as the data source to the rack instead of the Replayer. 

 Rack file: Neuro_OTC_Spikes_Demo.rck  

 Data file: Neuro_OTC_Spikes_Demo.mcd  

 Image file: OTC Spikes Image.jpg 

Please see also the MEA Application Notes for more information on the preparation techniques 
and experiments. 

You will learn in this chapter ... 

 How to define basic functions in your rack configuration: 

 Remove field potentials with a filter for a following spike extraction 

 Detect spikes 

 Analyze the spike rate 

 Visualize the spatial distribution of spike activity 

1.2 Preparations 

We recommend that you take some time for rebuilding the virtual rack for this application step  
by step in this tutorial, but if you prefer having a look at the completed rack or if you get stuck 
during the tutorial, you can also open the rack file "Neuro_OTC_Spikes_Demo.rck".  
Click Open on the File menu to open the rack file. 

1. Copy the complete MC_Rack Tutorial folder from the installation volume into the MC_Rack 
program directory with the following path "c:\Program Files\Multi Channel Systems\MC_Rack\" 

2.  Start MC_Rack or click New on the File menu to generate a new virtual rack file configuration. 

3. Click  on the toolbar to add a Replayer to your virtual rack. 

4. In the tree view pane of the virtual rack, select the Replayer and click the Replay File tab.  
Click the Browse button and browse to the Offline subfolder of the Tutorial folder,  
and load the data file Neuro_OTC_Spikes_Demo.mcd on the installation volume. 

1.3 Monitoring Raw Data 

You are ready to start to replay the data. We start with a simple Data Display for monitoring  
the raw data traces first. 

1. On the toolbar, click  to add a Data Display to the virtual rack and assign the Electrode  
Raw Data stream to it. Make sure that an 8x8 MEA Channel Map is loaded on the Layout page 
of the display. 

2. Click Start  (either on the Measurement menu, the toolbar, or the Rack tabbed page)  
to start the replaying of the data. 
 
Each virtual instrument in the rack configuration starts to process the channels and data streams 
that were assigned to it. For example, data is graphed in the displays, and so on. You can adjust 
the replaying speed on the Replayer tabbed page of the Replayer. The recorded data traces  
are displayed in the (continuous) Data Display. 

3. Zoom in the ranges so that you can see the signals clearly. 
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Peak Detection 

With Peak Detection switched off, you do not see any spike bursts, the data looks atypical  
for spikes. 

Peak Detection is a very important display option. The massive amount of data points retrieved 
in the range of the time axis, 1000 ms in this case, that means 2500 data points at a sampling rate 
of 25 kHz, are reduced to a few pixels on the display, about 90 pixels. That means, about 28 data 
points are reduced to one. Without Peak Detection, only every 28th data point is actually 
plotted. The other 27 are skipped. As you can imagine, faster signals like spikes cannot be 
identified in the data at all. 

With Peak Detection, the highest and the lowest data point of the five pixels in this example are 
taken and connected to a straight vertical line. This results in a much more realistic representation 
of the data. On the other hand, this feature needs a higher computer performance for the 
internal data handling. You may want to deselect this option when you have a limited computer 
performance, indicated by a Performance Limit error message., or if you do not need the 
feature, because you are recording slow field potentials only. 

1. Select Peak Detection on the display toolbar for a more realistic data representation, and start 
the Replayer again. 

On the following screen shots, you can see that the spikes are only visible if Peak Detection has 
been selected. This option affects only the graphical representation of data, not the recorded 
or exported data. 

 

Fig. 1 Without Peak Detection 

Due to the graphical representation of the data, no fast signals like spikes are visible in the 
display. 

 

Fig. 2 With Peak Detection 

This is the same data as and display ranges as in the preceding screen shot. With Peak Detection, 
you now see bursting activity on the upper left half of the MEA.  
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1.4 Removing Field Potentials with a Filter 

1. Zoom in the signals a bit more. As you can see, spike signals are superimposed on  
local field potentials, which are built up by signals of cells firing simultaneously. 
 

 
 
If you would try to detect peaks by a threshold, you would miss most of the peaks. To circumvent 
this problem, you can use a digital filter that removes slow signals, that is, field potentials. In the 
current version of MC_Rack, a second order Butterworth filter is available. Please be aware that  
all filters deform signals. It has always to be made a compromise between good filtering and low 
signal deformation. (The other option would be to use the Slope mode of the Spike Sorter.  
In this mode, the Spike Sorter detects spikes on the basis of the waveform instead of a threshold, 
and thus is able to extract spike regardless of the baseline or underlying field potentials.) 

2. Click the Delete Instrument  button to remove the Data Display again to save computer 
performance. 

3. On the toolbar, click  to add a Filter to your rack. 

4. Click the Channels tab and select all channels. 
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5. Click the Filter tab. 
 

 

6. Select High Pass. 
You can choose between two filter types: Low Pass and High Pass. As the name suggests,  
a low pass filter passes the lower frequency components but attenuates the higher frequency 
components of signals. To remove slow components (with a low frequency) and to let pass high 
frequency signals, you need a high-pass filter. 

7. Type in 200 Hz as the Cutoff Frequency. The high-pass filter now cuts off frequencies below  
the specified 200 Hz. For spike activity, you usually use a Cutoff Frequency of 200 Hz or above, 
depending on the frequency of the noise and the slope / waveform of the spikes. The cutoff 
frequency of the filter must be compatible with the frequencies present in the signal of interest. 

8. Add a Data Display to your rack. Load the 8x8 MEA Channel Map. On the Data tabbed page, 
select the Electrode Raw Data and the Filtered Data streams. 

9. Click Start  to start the Replayer, and zoom the traces. 
The filtered data traces are displayed superimposed (magenta) on the unfiltered data (blue).  
You see that the field potentials have been more or less removed. You can now remove the 
display again from the rack to save computer performance. 
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1.5 Detecting Spikes 

The Spike Sorter detects spikes and features an online (or offline) spike sorting into up to three 
units. The spike cutouts form a new data stream that can be analyzed further (or recorded to the 
data file). 

There are two modes for detecting spikes with MC_Rack. One method uses a threshold, the other 
recognizes the amplitude and slope of the waveform of interest. Both methods regard either 
the rise or the fall of the input signal, depending on your settings. 

The threshold method is especially useful if the overall baseline is stable, and spikes appear 
approximately on the same height. If local field potentials are underlying the spikes, or if you 
have an unstable baseline, spikes will be missed, or noise signals may be detected as spikes with 
the threshold method. In this case, the Slope method is more appropriate. 

In this tutorial, we have used a digital high pass Filter to remove field potentials and to prepare 
the data for using the Threshold method. 

The Spike Sorter has a special display where you can either set the threshold, or sort spikes  
in an interactive kind of way. You can set the level for each channel separately (manually or 
automatically), or you can choose the same level for all channels. 

1. In the tree view pane of the virtual rack, select the Filter. On the toolbar, click  to add  
a Spike Sorter in series with the Filter to the virtual rack. (If you put the Spike Sorter  
in parallel to the Filter, it would not be possible to use the filtered data stream as an input  
stream for the Spike Sorter, because virtual instruments can only use the output streams of  
other virtual instruments that are upstream in the tree view as input streams.) The Spike Sorter 
display appears (in detection mode). 

2. Click the Channels tab and assign the Filtered Data stream to the Spike Sorter. 
 

 

3. Select the Peak Detection option of the display. Click the Start button and zoom the display 
until you can see the signals clearly. You see that the baseline is on a similar level for all channels 
and that the spikes are quite small (approximately 10 to 15 μV). 

4. Click the Detection tab. Make sure the Threshold method is selected. You can now set the 
detection threshold. Start with a value of 15 μV. 

5. Type in 15 in the text box. This value is now applied only to the selected channel. Under  
Apply to All, click Level to apply the new detection level to all channels. Spike cutouts appear  
in a different color in the display. The detection level is visible as a horizontal straight line.  
You see that the level could be set a bit higher though to catch more spikes. 
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6. Use the option Tune all levels to modify the level of all channels until the detection level  
seems to be optimized (approximately to -12 μV). You can also click and drag the detection  
level (black line) of each channel in the Spike Sorter display with your mouse. 
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1.6 Analyzing the Spike Rate 

Hint: Instead of using the time-interval based Analyzer, you can also use the event-based  
Spike Analyzer for extracting the spike rate and the interspike-interval. Please see MC_Rack 
Features > Analyzing Data > Analyzing Data for details. 

1. On the toolbar, click  to add an Analyzer in series with the Spike Sorter to the virtual rack. 
(You cannot put the Analyzer in parallel to the Spike Sorter, because virtual instruments can 
only use the output streams of other virtual instruments that are upstream in the tree view as 
input streams.) 

2. In the tree view pane of the virtual rack, select the Analyzer. Click the Channels tab. 

3. Select all channels of the Spikes data stream. 

4. Click the Analyzer tab. 

5. Select Rate. 

 

The data stream is continuous, therefore the Analyzer should process the data continuously, too. 
Internally, the Analyzer operates on distinct pieces of data, so called bins. You can enter the bin 
size. Standard is 1 s, which is ok if the overall spike activity is going to be monitored. 
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1.7 Plotting the Spike Rate 

For plotting extracted parameters, we will need a Parameter Display, which features are 
optimized for graphing Parameter streams. 

1. In the tree view pane of the virtual rack, select the Analyzer and click  on the toolbar to add  
a Parameter Display in serial with the Analyzer to the virtual rack. (It would not be possible  
to add the Parameter Display in parallel to the Analyzer, as the replayed data file does not 
contain any parameter streams as input streams for the display, and virtual instruments can only 
use the output streams of other virtual instruments that are upstream in the virtual rack tree.) 

2. In the tree view pane of the virtual rack, select the Parameter Display and rename it  
to Spike Rate. Click the Layout tab to load the MEA Channel Map. 

3. Click the Data tab and select the Parameter 1 Rate stream. 
 

 

4. Start the Replayer. 
The spike rate is plotted over time. You clearly see the two active tissues and the non-active  
area in the middle. The highest rate is about 60 Hz. 
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1.8 Visualizing the Spatial Distribution 

The Trace plot is good for monitoring the spike rate over the complete recording time.  
A False Color plot is the better choice for getting an idea of the spatial distribution and  
whether two regions fire simultaneously or independently. In a False Color plot, a specific  
color map is assigned to the parameter values, in this case, the spike rate. 

 Select the Parameter Display and click the Color tab. 
You see four color palettes. The selected Color Map defines the colors used for the plot.  
Each Color Map consists of 64 different colors arranged in a particular order. 

The minimum and maximum range of the y-axis (defined in the Range page) is assigned  
to the selected Color Map, that is, the most left color corresponds to the minimum y-value 
selected, and the most right color corresponds to the maximum y-value. The interval 
between min and max is straight-proportional to the colors in-between. The color of the actual 
value is picked from the Color Map accordingly. Parameter values outside the defined 
min/max range are plotted in Black. 

Example: If the range was set from min = 0 Hz to max = 64 Hz, each color of the map would 
correspond to 1 Hz steps. Spike rates lower than 1 Hz would then be plotted as the first (most left) 
color of the color map, spike rates between 1 Hz and 2 Hz would be plotted as the second color of 
the color map, and so on. A value above 64 Hz would be plotted in black.  

That means, for example, for the Gray Color Map, the lighter the color becomes,  
the higher is the spike rate. 

 

1. Click the Data tab and select the False Color plot type. 

2. Click the Ranges tab and set the y-axis to the maximum rate, that is, 100 Hz. 

3. Start the Replayer. 
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The first screen shot shows the right region firing, the second shows the left slice firing.  
You see now clearly that both brain slices fire independently.  
The Jet Color Map has been used here. 
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2 Saving the Rack and Saving Data 

2.1 Saving a Rack 

Save the virtual rack configuration if you like to keep it for future use, for example for an offline 
analysis of identical data recorded in another experiment. 

1. On the File menu, click Save As. 

2. The Save As dialog box opens. 

3. Browse your folders and select a path. 

4. Enter a file name and confirm by clicking Save. 

The file extension for the rack files is .rck. 

2.2 Selecting Data Streams for Recording 

MC_Rack's philosophy is to strictly separate the actions of all virtual instruments in a rack.  
That means, that you could record to hard disk completely different data streams and channels 
than you monitor on the screen. This has the advantage that you can store exactly the channels 
you are interested in, but it also has the slight disadvantage that all virtual instruments have to be 
set up separately. Please be especially careful when configuring the Recorder, to avoid data loss. 

When you have finished setting up the rack, you can select the data streams and channels that 
you want to save to the data file specified in the Recorder. 

Selecting data streams and channels for recording 

The fate of each single channel is independent from other channels. You can pick exactly the 
channels you like to save from all generated data streams. For example, you can decide to save 
only one channel of raw data, but the peak-to-peak amplitude results of all, or of a specific 
selection of channels. 

1. Select the Recorder in the virtual rack tree view pane and then click the Channels tabbed page. 
On the white pane on the left of the Channels page, you see the data streams that are available 
with your rack configuration. When replaying data, you are generally more interested in the 
parameter data streams, but you can rerecord the raw data as well, in case that you want to save 
the raw data and the extracted parameters to the same data file. 
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2. Click the data stream that you are interested in, generally the parameter streams. 
The available electrode channels appear in a button array on the right side. Parameter stream 1  
is generated by the first analyzer in the rack (here: for extracting the peak-peak amplitude), 
parameter 2 is generated by the second analyzer (here: for extracting the slope). 
 

 

3. You can now either select all channels by clicking the check box next to the data stream name,  
or you can pick single channels by clicking the corresponding buttons. For more information, 
please see "Channel Selection" in the MC_Rack Features section. Only data from the selected 
channels will be saved to the hard disk. 

2.3 Creating a Data File 

If you want to write the parameters that you will extract in an offline analysis to the hard disk, 
you have to specify the file name and path in the Recorder. (It is not possible to change or 
overwrite existing data files in MC_Rack, for example, adding the spike rate to an existing data 
file, but you can record the raw data together with the spike rate stream to the same file.) 

Choosing the file name and path 

1. Click the Recorder tab. 

2. Browse your folders and select a path. 

3. Type a file name into the text box. 

4. Confirm by clicking Save. 

The data file is then generated automatically when you start MC_Rack in recording mode.  
The file extension for the data files is *.mcd. 
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File size limit 

When the maximum file size specified by the user has been reached, a new file is generated 
automatically. The file name is extended by four digits, counting up, for example  
LTP-Parameters0001.mcd, LTP-Parameters0002.mcd, and so on. 

If you rather prefer that the recording is completely stopped when a file has reached the 
maximum size, please select the option Auto Stop. 

For information on more options, please see "Generating Data Files" in the MC_Rack Features 
section. 

Selecting data streams and channels 

As has been said before, the fate of each single channel is independent from other channels. 
You can pick exactly the channels you like to save from all generated data streams. For example, 
you can decide to save only one channel of raw data, but the peak-to-peak amplitude results 
of all, or of a specific selection of channels. 

 Click the Channels tab. 

As long as the rack is still empty, you see an empty box. There are no channels available at this 
point, because you have not chosen a data source yet (MC_Card for online data acquisition or 
Replayer for replaying data files). Without a data source, there are no data streams available  
for recording. Remember later, when you have completed the rack, to assign the channels that 
you like to save to the data file to the Recorder. 

After you added a data source, you will see the electrode raw data streams provided by the data 
source (for example, electrode raw data, analog data, and digital data from the MC_Card, or the 
data streams included in the data file loaded into the Replayer). If the rack file contains virtual 
instruments that generate data streams such as Spikes from a Spike Sorter or Parameter streams 
from an Analyzer, these data streams will be available for recording as well. 

2.4 Starting Data Acquisition and Recording 

Now that you have completed the virtual rack, you are ready to start the rack. 

 Click Start  (either on the Measurement menu, the toolbar, or the Rack tabbed page)  
to start the data acquisition. Each virtual instrument in your rack starts to process the channels 
and data streams that were assigned to it. 

 Click first Record  and then Start  to write data to the hard disk. The data from the 
electrodes selected in the Recorder is saved to the file and location specified in the Recorder. 

 

 Click Stop  to stop the data acquisition. 

 

Warning: Only data of the channels and data streams that were selected in the Recorder are 
saved in your data file when you start a recording. Data is only saved to the hard disk when the 
red Record button is pressed in. Make always sure that you have selected all channels of interest, 
and that the Record button is active before starting an experiment to avoid data loss. 

 


